IMPORTANT: Server shutdown Nov. 3

Discussion in 'Forum Announcements and Feedback' started by Daniel Mosquin, Oct 31, 2005.

  1. Daniel Mosquin

    Daniel Mosquin Paragon of Plants UBC Botanical Garden Forums Administrator Forums Moderator 10 Years

    Messages:
    10,216
    Likes Received:
    423
    Location:
    Vancouver, British Columbia, Canada
    On Oct.30 at 11:30 PM PDT, I attempted to upgrade the software running the web server. Unfortunately, it did not go smoothly, and the end result was that the site was down for 12 hours (and the software was never upgraded).

    Now that it is patched back together, it only seems to "mostly" work - there are a few quirks, particularly when the forum software is supposed to redirect you elsewhere. I think this mostly affects us as the admins (e.g., moving threads), but it might crop up when you are doing something. If it does occur, you'll note that "nothing seems to be happening" after you press submit (though it is actually working correctly in the background, just not for what you see).

    Also, I've noted the forums seem a bit slower than usual. I'd appreciate if anyone else could confirm that.

    Thanks,
    Daniel
     
    Last edited: Nov 2, 2005
  2. Michael F

    Michael F Paragon of Plants Forums Moderator 10 Years

    Messages:
    10,978
    Likes Received:
    264
    Location:
    Britain zone 8/9
    Re: Server issues

    Thanks for the info! (much better than some forums I can think of :-)

    I got the impression it was perhaps a little slow, though I'm not certain.
     
  3. Eric La Fountaine

    Eric La Fountaine Contributor UBC Botanical Garden Forums Administrator Forums Moderator 10 Years

    Messages:
    3,462
    Likes Received:
    174
    Location:
    Vancouver
    Re: Server issues - attachments

    I am not able to upload images. This may be a problem for a little while yet. Can anyone confirm this. Please test an attachment and post here on whether it works or not.
     
  4. Daniel Mosquin

    Daniel Mosquin Paragon of Plants UBC Botanical Garden Forums Administrator Forums Moderator 10 Years

    Messages:
    10,216
    Likes Received:
    423
    Location:
    Vancouver, British Columbia, Canada
    Re: Server issues

    testing image attachments...
     
  5. Daniel Mosquin

    Daniel Mosquin Paragon of Plants UBC Botanical Garden Forums Administrator Forums Moderator 10 Years

    Messages:
    10,216
    Likes Received:
    423
    Location:
    Vancouver, British Columbia, Canada
    Re: Server issues

    Ayup. That'd be a huge issue. I don't think we (the IT admin in the faculty and myself) are going to be able to tackle that until tomorrow AM, unless I manage to figure it out by myself tonight.
     
  6. Daniel Mosquin

    Daniel Mosquin Paragon of Plants UBC Botanical Garden Forums Administrator Forums Moderator 10 Years

    Messages:
    10,216
    Likes Received:
    423
    Location:
    Vancouver, British Columbia, Canada
    Re: Server issues

    Another attempt at uploading...

    Still no go.
     
  7. Michael F

    Michael F Paragon of Plants Forums Moderator 10 Years

    Messages:
    10,978
    Likes Received:
    264
    Location:
    Britain zone 8/9
    Re: Server issues

    Image test . . .

    Looks like nothing's happening
     
  8. Daniel Mosquin

    Daniel Mosquin Paragon of Plants UBC Botanical Garden Forums Administrator Forums Moderator 10 Years

    Messages:
    10,216
    Likes Received:
    423
    Location:
    Vancouver, British Columbia, Canada
    Re: Server issues

    Yes, so here's the scoop near as I can tell:

    In the course of attempting to update, and then needing to roll back both, the web server software and the scripting language (PHP), something has gone out of sync with either caching or header information.

    What's occurring from a functional point of view is that the server is not letting the browser know what's going on during certain actions. So, the image is actually being uploaded, but the server isn't letting your browser know that it's done, and it just hangs.

    Edmund (the faculty's IT admin) and myself will look at it in the morning. I just spent another couple hours eliminating some possibilities, and I think it's been sufficiently narrowed down that we now know the next course of action that must be taken.

    I see that the server also muddled up all by itself earlier this evening, so that suggests that what we marginally have now won't work in the long-term anyway, since it seems a bit unstable.

    Anyway, as a long-term plan, I guess I'm going to have to lobby for a second server so that I can make an update on one server and verify everything works before making the update on the other - and if it doesn't work on the first, rolling back everything would be a cinch.
     
  9. Daniel Mosquin

    Daniel Mosquin Paragon of Plants UBC Botanical Garden Forums Administrator Forums Moderator 10 Years

    Messages:
    10,216
    Likes Received:
    423
    Location:
    Vancouver, British Columbia, Canada
    Re: Server issues

    *bump* We're still looking into this. Nothing much to update yet.
     
  10. Junglekeeper

    Junglekeeper Esteemed Contributor 10 Years

    Messages:
    5,504
    Likes Received:
    389
    Location:
    Vancouver BC Canada
    Re: Server issues

    The gremlins must have had an early start on Halloween this year.

    I couldn't even load the main forum page until now. Thanks for keeping us informed and for your efforts in fixing the problem.
     
  11. Daniel Mosquin

    Daniel Mosquin Paragon of Plants UBC Botanical Garden Forums Administrator Forums Moderator 10 Years

    Messages:
    10,216
    Likes Received:
    423
    Location:
    Vancouver, British Columbia, Canada
    Re: Server issues

    another test... and another failure. *sigh*
     
  12. Daniel Mosquin

    Daniel Mosquin Paragon of Plants UBC Botanical Garden Forums Administrator Forums Moderator 10 Years

    Messages:
    10,216
    Likes Received:
    423
    Location:
    Vancouver, British Columbia, Canada
    Re: Server issues

    testing again
     
  13. Daniel Mosquin

    Daniel Mosquin Paragon of Plants UBC Botanical Garden Forums Administrator Forums Moderator 10 Years

    Messages:
    10,216
    Likes Received:
    423
    Location:
    Vancouver, British Columbia, Canada
    Re: Server issues

    Well, all I can say is I've eliminated another possibility. Down to 2.
     
  14. Daniel Mosquin

    Daniel Mosquin Paragon of Plants UBC Botanical Garden Forums Administrator Forums Moderator 10 Years

    Messages:
    10,216
    Likes Received:
    423
    Location:
    Vancouver, British Columbia, Canada
    Re: Server issues

    Progress.
     

    Attached Files:

  15. Daniel Mosquin

    Daniel Mosquin Paragon of Plants UBC Botanical Garden Forums Administrator Forums Moderator 10 Years

    Messages:
    10,216
    Likes Received:
    423
    Location:
    Vancouver, British Columbia, Canada
    Re: Server issues

    Still not having much luck, and as you can see, I've muddled one of the templates because of the scripting language not working / updating.
     
  16. Daniel Mosquin

    Daniel Mosquin Paragon of Plants UBC Botanical Garden Forums Administrator Forums Moderator 10 Years

    Messages:
    10,216
    Likes Received:
    423
    Location:
    Vancouver, British Columbia, Canada
    Re: Server issues

    Ok, well, it looks like we're going to have reinstall all of the server software. This will likely take half a day, and is scheduled to occur Nov 3 from 7:45 AM until it's done (should be back up by mid-afternoon).

    So, expect things to be as flaky tomorrow as they were today while we battle the gremlins.
     

Share This Page