Azalea buds turn brown and won't open

Discussion in 'Indoor and Greenhouse Plants' started by Fossil, May 3, 2014.

  1. Fossil

    Fossil Active Member 10 Years

    Messages:
    53
    Likes Received:
    0
    Location:
    Buchanan,Sask. Canada
    I have an azalea plant that was given to me a couple of years ago when I lived in BC. I moved to Saskatchewan last September and since then have only had two flowers on the plant. All the buds are brown when they appear and refuse to open. The plant itself is healthy and has lots of new leaf growth - I just don't know why I can't get it to flower and why the buds are brown.

    Can somebody help please?
     
  2. chimera

    chimera Well-Known Member 10 Years

    Messages:
    1,771
    Likes Received:
    60
    Location:
    Fraser Valley, B.C. ,Canada
  3. Fossil

    Fossil Active Member 10 Years

    Messages:
    53
    Likes Received:
    0
    Location:
    Buchanan,Sask. Canada
    Sorry, don't understand.
     
  4. saltcedar

    saltcedar Rising Contributor 10 Years

    Messages:
    4,400
    Likes Received:
    2
    Location:
    Austin, Tx
  5. Sundrop

    Sundrop Well-Known Member

    Messages:
    2,057
    Likes Received:
    97
    Location:
    Kootenays, BC, Canada
    It is just Internet slang.
    eom means end of message. Chimera probably wanted to say something, but changed his mind.
    hth means hope this help.
     
  6. chimera

    chimera Well-Known Member 10 Years

    Messages:
    1,771
    Likes Received:
    60
    Location:
    Fraser Valley, B.C. ,Canada
    Yes, re eom, thanks sundrop.

    I was thinking the buds may have been frost bitten growing outside, then realized the topic is for "indoor and greenhouse plants".
     

Share This Page