Feedback on new Forum Software

Discussion in 'Forum Announcements and Feedback' started by Daniel Mosquin, Oct 15, 2015.

  1. Junglekeeper

    Junglekeeper Esteemed Contributor 10 Years

    Messages:
    5,462
    Likes Received:
    365
    Location:
    Vancouver BC Canada
    I think it would be acceptable to have a very short period, say five minutes, in which a post can be deleted. This would allow for outright mistakes or errors in judgement to be remedied.
     
    wcutler likes this.
  2. Sundrop

    Sundrop Well-Known Member

    Messages:
    2,057
    Likes Received:
    97
    Location:
    Kootenays, BC, Canada
    I just hit Like in the post #25 but wanted to see how Unlike works so hit Unlike after that. It seems, it doesn't work?
     
  3. togata57

    togata57 Contributor 10 Years

    Messages:
    3,157
    Likes Received:
    132
    Location:
    Columbus, Ohio
    When I receive a notification that there has been a post on a thread, I click on the 'View This Thread' box within it---and am taken to the FIRST post. Not the most recent. The first. Which necessitates scrolling through pp of entries. Progress, I guess.
    I abhor this new lack-of-color scheme. Like staring into a fluorescent bulb.
    Seems that 'progress' means minute attention paid to cute addenda, rather than to the ostensible purpose of this Forum.
    What's next? Emoticons? Or maybe those animated gifs that created such a furore a few years ago.
    Gotta go now before my retinas melt.
     
  4. wcutler

    wcutler Esteemed Contributor Forums Moderator VCBF Cherry Scout 10 Years

    Messages:
    9,138
    Likes Received:
    1,238
    Location:
    Vancouver, BC Canada
    I agree with this. And I Liked it.

    I'm not seeing any likes. Is there Likes count on the messages visible somewhere? I liked Michael's message to give him an example of how it would work to get a Like rather than a reply.
     
  5. Sundrop

    Sundrop Well-Known Member

    Messages:
    2,057
    Likes Received:
    97
    Location:
    Kootenays, BC, Canada
    The Like is there on the post and on your profile. It is ok, but I would like to have an option to delete my Likes if I would like to.
     
    Last edited by a moderator: Oct 17, 2015
  6. Junglekeeper

    Junglekeeper Esteemed Contributor 10 Years

    Messages:
    5,462
    Likes Received:
    365
    Location:
    Vancouver BC Canada
    @Daniel Mosquin You may want to update the message on the Garden's home page on the status of the forums now that they're back online.
     
  7. wcutler

    wcutler Esteemed Contributor Forums Moderator VCBF Cherry Scout 10 Years

    Messages:
    9,138
    Likes Received:
    1,238
    Location:
    Vancouver, BC Canada
    I see. Numbers 22 and 26 have Likes, and it shows under the signature. Was that really there when I looked before? Never mind, I see it now. Thanks.
     
  8. Junglekeeper

    Junglekeeper Esteemed Contributor 10 Years

    Messages:
    5,462
    Likes Received:
    365
    Location:
    Vancouver BC Canada
    The View This Thread button is working for me if you're referring to the one in an email notification. The URL it generates suggests the thread is being positioned at the post that triggered the notification.
     
  9. Daniel Mosquin

    Daniel Mosquin Paragon of Plants UBC Botanical Garden Forums Administrator Forums Moderator 10 Years

    Messages:
    10,149
    Likes Received:
    393
    Location:
    Vancouver, British Columbia, Canada
    Right you are -- I didn't realize this. It used to be 90 days for the Contributor (long-time member) usergroup on the old forums. I had it set as 30 minutes for the replacement Supporter usergroup, so that'd be much shorter. The permissions, if I've set them up correctly now, should be this:

    Registered usergroup: can edit messages by self within 5 minutes, can't delete messages by self
    Verified usergroup (confirmed email address with 5 posted messages): can edit messages by self within 5 minutes, can delete messages by self within 5 minutes
    Supporter usergroup (confirmed email address with 50 messages): can edit messages by self infinitely, can delete messages by self infinitely

    (but see my notes below re: some other concerns about the length of time)

    As noted by Wendy, my time spent on these new forums is getting the function up to what we were used to, not the look. The look will come later. It will return to a green colour palette.

    Wendy, all users can only soft-delete their own messages (not remove from the database). As it happens, I've installed a tool where admins and moderators can monitor the soft-deleted messages, so we have a one-click way of checking these on the entire forums (which is great for reducing clutter). Similarly, there is now an "edit history", much like how Wikipedia stores histories of edited entries. Admins (and mods?) can see these and revert posts back to previous versions.

    Looks like it works to me? I looked at message 25 and it didn't have any likes. I then tried to Like and Unlike your message, and it worked successfully. Give it another go, and let me know if it isn't working -- it may be a permissions issue.

    Clicking on the View This Thread box should take you to the first unread message in the thread. Clicking on the thread title above it should take you to the first unread message in the thread. Clicking on the thread title below it (after the "This message was sent to you because you opted to watch the thread" bit in the email) takes you to the first post in the thread. I hovered over this set of links in my email program, and for the first (the View This Thread box) received: "forums-link-to-thread"/unread; for the second (the thread title above it) received: "forums-link-to-thread"/#post-343313 (which was the first unread post); and for the third received: "forums-link-to-thread". Check it again on the next emails, please, because what you are describing is not the intent nor my experience.

    As for the colour scheme, as mentioned previously in the thread by myself and wcutler, this scheme is only temporary while we work on the function and purpose of the forum.

    I don't know what you mean by cute addenda? We purchase the forums software, and then make customizations to fit our purposes. Most of what you are seeing is what comes out of the box, and it takes time to tweak it as I am learning it. All that added (addenda) with my time and effort so far has been for function (with the exception of making a style adjustment for signature line separation and a style adjustment for separating the message boxes from each other more readily). So that statement doesn't quite match with where the work is being directed toward.

    As for emoticons: funny you should mention it. I did try to remove them, but I haven't gone far enough yet, as someone managed to sneak one into a message somewhere. They come default with the software, and seem to be more difficult to remove than the previous software.

    Addressed above.

    Noted, I'll tell the staff person responsible.

    Thanks, yes, my experience too.
     
  10. wcutler

    wcutler Esteemed Contributor Forums Moderator VCBF Cherry Scout 10 Years

    Messages:
    9,138
    Likes Received:
    1,238
    Location:
    Vancouver, BC Canada
    That's an improvement over the previous system, where the single link in the message went to the last post. It's even strange for me to say that's an improvement, since I like seeing the last post first, but that notification sometimes led me to miss noticing that the notification was for a posting before the one I was taken to.

    Hey, I've just learned that after I do a quoted reply, I can go pick up a different quote to change it or add another quote. They have totally nailed this feature. And it's so much better when doing a reply to be able to see the real postings, with the posted dates and posting numbers.
     
  11. wcutler

    wcutler Esteemed Contributor Forums Moderator VCBF Cherry Scout 10 Years

    Messages:
    9,138
    Likes Received:
    1,238
    Location:
    Vancouver, BC Canada
    I don't think I even mentioned how great this looks on my Android phone. It's a huge improvement. It's like we got an app for free.
     
  12. Junglekeeper

    Junglekeeper Esteemed Contributor 10 Years

    Messages:
    5,462
    Likes Received:
    365
    Location:
    Vancouver BC Canada
    @Daniel Mosquin
    • BB code [IMG] was disabled in previous system. May want to do same here.
      Edit:
      I just noticed that [IMG] automatically converts to [ATTACH]. Does this mean the image is automatically uploaded?
    • You may want to have a look at this light green style: Default Style Green 1.2.2 (compatible with XF 1.2)
    • Which version of xenForo are we on? I couldn't find it anywhere.
     
    Last edited: Oct 19, 2015
  13. togata57

    togata57 Contributor 10 Years

    Messages:
    3,157
    Likes Received:
    132
    Location:
    Columbus, Ohio
    Daniel is correct. These features are not addenda but integral parts of the software.
    My mistake to speak from my own point of view.

    XenForo has a color scheme named Flexile Dark-Green. Attractive and easy on the eyes.
    There is a button at the bottom of the title page (another forum) labeled 'Quark Style Chooser' which, when clicked upon, permits this choice.
    Would it not be wonderful if UBC Forum members were allowed this option?
     
  14. Silver surfer

    Silver surfer Contributor 10 Years

    Messages:
    3,810
    Likes Received:
    217
    Location:
    PERTHSHIRE. SCOTLAND.UK
    Just posted my first thread.
    Loading pics is magic.
    So very quick and easy.
     
  15. emery

    emery Renowned Contributor Maple Society 10 Years

    Messages:
    2,667
    Likes Received:
    1,367
    Location:
    Normandie, France
    @Daniel Mosquin Another comment on loading images. I tried to multi-select and then drag and drop photos into the post window, it didn't work. It may be an artifact of my KDE environment, but it seems to me this should work at least on Windows/Mac. Has anyone tried it?

    I then opened the Upload a File dialog, which filtered for common image formats. However dot-JPG, which is how my Canon Ixus stores images, was not listed, and running Firefox 41.0 there was no was to change the filter: the pull down menu did not allow any changes. I finally got it to change by dragging a dot-JPG entitled pic into this menu area, at which point my files showed up and I was able to upload. Still I posit this is probably a little much for most Canon owners to go through.

    -E

    P.S. Love the disabling of emoticons. Seems to "not work" but I note the smiley is still in the default HTML editor menu bar, this may confuse folks some.
     
  16. Junglekeeper

    Junglekeeper Esteemed Contributor 10 Years

    Messages:
    5,462
    Likes Received:
    365
    Location:
    Vancouver BC Canada
    I feel somewhat embarrassed asking but how do I retrieve a list of images I've uploaded in the past? When I click on Media Gallery Embed (i.e. The camera icon) I get the message "You have not added any media yet." Pictures which I uploaded still appear in old posts so they're stored somewhere.
     
    wcutler likes this.
  17. wcutler

    wcutler Esteemed Contributor Forums Moderator VCBF Cherry Scout 10 Years

    Messages:
    9,138
    Likes Received:
    1,238
    Location:
    Vancouver, BC Canada
    I tried it last night and it didn't work, normal Windows 10 environment. It showed that not-allowed-here symbol. I've just done this now on MS Edge, Firefox and Chrome in the Testbed. It only doesn't work in Edge; the other two are fine for single or multiple photos dragged in. BUT, Edge isn't allowing me to drag even a single photo. @emery, you dragged one photo. I'm guessing using the same browser, you can not now do that. Could you have been using a different browser the first time?
     
  18. wcutler

    wcutler Esteemed Contributor Forums Moderator VCBF Cherry Scout 10 Years

    Messages:
    9,138
    Likes Received:
    1,238
    Location:
    Vancouver, BC Canada
    Based on the definition of Media on the Media icon, it seems to mean video. I'm used to the word meaning any attachment in WordPress, so I was expecting it to include photos. Or is it supposed to for the Media Gallery? That's a bit confusing. That would be great to have all our uploaded photos in our media gallery. Maybe I'm the reason why you wouldn't want to - too many.
     
  19. Junglekeeper

    Junglekeeper Esteemed Contributor 10 Years

    Messages:
    5,462
    Likes Received:
    365
    Location:
    Vancouver BC Canada
    I'm going by the icon's picture. A strip of film in the Media icon represents movies; it follows then that a camera in the Media Gallery Embed would represent images/pictures, or so I thought.
     
  20. wcutler

    wcutler Esteemed Contributor Forums Moderator VCBF Cherry Scout 10 Years

    Messages:
    9,138
    Likes Received:
    1,238
    Location:
    Vancouver, BC Canada
    Well, the first one, that just says Media, is to embed from a URL, an external source. The camera one is to embed from the gallery. It needs to have something for the icon. It does look like the word is used differently on the two icons, where the gallery includes photos as well as videos.
     
  21. Daniel Mosquin

    Daniel Mosquin Paragon of Plants UBC Botanical Garden Forums Administrator Forums Moderator 10 Years

    Messages:
    10,149
    Likes Received:
    393
    Location:
    Vancouver, British Columbia, Canada
    I'll look into this when the styles are addressed. Maybe this week -- I can't start working on getting Botany Photo of the Day revived until some decisions are made about the main web site, so I'll have time to do some of this for the forums, I think.

    See Wendy's note below -- that sounds like an issue of browser compatibility. There may be an add-on fix, I will have to look (or new versions of the software will fix).

    Yes, I need to install an add-on to remove that from the editor bar re: emoticons.

    Media Gallery is an add-on product to XenForo: XenForo Media Gallery | XenForo

    Maybe this answers a few questions about it: Question about Media Gallery

    It isn't tied to what you upload as attachments (though it can be drawn upon for that).

    See above.
     
  22. Daniel Mosquin

    Daniel Mosquin Paragon of Plants UBC Botanical Garden Forums Administrator Forums Moderator 10 Years

    Messages:
    10,149
    Likes Received:
    393
    Location:
    Vancouver, British Columbia, Canada
    Oops, missed replying to this above.

    I've installed an add-on that takes care of the IMG issue where people hotlink to images and then the link dies. The add-on retrieves the image, thumbnails it, and stores it locally. That should work for the long term (and also prevent the embarrassing situation where someone hot-links and then the owner of the hot-linked image swaps it out for something... inappropriate).

    Noted re: styles.

    We are on 1.5.1. I suspect it isn't displayed on the forums software as that is an advertisement to people who know how to hack specific versions.
     
  23. wcutler

    wcutler Esteemed Contributor Forums Moderator VCBF Cherry Scout 10 Years

    Messages:
    9,138
    Likes Received:
    1,238
    Location:
    Vancouver, BC Canada
    I'm understanding this to mean that I'm not saving any system storage by linking to a photo in another posting, just saving my having to save the photo to upload it in the new posting where I want to use it.

    (Gosh I love the way these reply quotes work.) That says the thread photos are in a different container, managed differently, so those photos can't go in the media gallery, if I understand that correctly.
    Here's another info link about the Media Gallery: XenForo Media Gallery
    And a relevant thread, making a similar request: View Pictures across Site on Media Gallery.
    Well, and another, mentioned in the previous thread: Add-on - Gallery Add On That Pulls Images From Main Forum.

    I originally thought having it just by user would be enough, but all by forum could be useful too. I didn't read carefully enough to determine if the people who did it duplicated the storage or if the gallery was composed of links. I suppose if links, then you would get broken links when photos are deleted, though databases are supposed to deal with that kind of thing.
     
  24. Daniel Mosquin

    Daniel Mosquin Paragon of Plants UBC Botanical Garden Forums Administrator Forums Moderator 10 Years

    Messages:
    10,149
    Likes Received:
    393
    Location:
    Vancouver, British Columbia, Canada
    The hotlink add-on works on externally-hosted images. I don't think it bothers with internal ones. So yes, you are saving space.
     
  25. togata57

    togata57 Contributor 10 Years

    Messages:
    3,157
    Likes Received:
    132
    Location:
    Columbus, Ohio
    Prefer the old member list (alphabetical) to the new (prioritized by number of posts).
    When I look for someone I search for a name. Does anyone search by number of posts? Or know this number?
     
    emery and wcutler like this.

Share This Page