rotting roses not the bushes

Discussion in 'Rosa (roses)' started by brjlhlej, Jun 17, 2007.

  1. brjlhlej

    brjlhlej Member

    Messages:
    9
    Likes Received:
    0
    Location:
    Lexington Park, MD USA
    I have about 20 rose bushes and have been having the same problem with all of them. After they get the buds on them before they actually open they start to rot and dont open. If some of them do get to open they look terrible. I have never had this problem before and was thinking maybe it was lack of rain. I water all the time but we have city water and I was thinking that maybe that might not be good either but it never hurt them before. Does anyone else have the same problem or maybe a solution to the problem. Help
     

    Attached Files:

  2. Margaret

    Margaret Active Member 10 Years

    Messages:
    380
    Likes Received:
    0
    Location:
    Sunshine Coast, B C Canada
    Do not have a definitive answer - just a few observations. I have a very large (7ft tall rose) and have noticed that the buds and blossoms which hang downwards and are in the shade of a staircase often rot and this usually happens when we have had several days of heavy rain. Water seems to stay around in these areas. You mention that you have had a lack of rain but I wonder if you are watering the foliage as well as the roots and if this water is causing the rot. Are any of your other plants also suffering?
    Just a thought but I am sure others will have ideas.
    Good luck.
    Margaret
     
  3. brjlhlej

    brjlhlej Member

    Messages:
    9
    Likes Received:
    0
    Location:
    Lexington Park, MD USA
    nothing else is rotting just the roses but not the bushes. i was wondering if it may be the chlorine in the water doing something to them. last year they were perfect but then we had rain also.
     
  4. smachohalla

    smachohalla Member

    Messages:
    1
    Likes Received:
    0
    Location:
    Pondicherry India
    Hi guys,
    glad i could find the problem quoted here. even i have the same issue of the buds rotting before opening. The plants were kept in the same place same conditions, same kind of watering etc but i noticed that as the season changed to a colder misty early morning and then a suddden sunrise and heat - coz im in india.. the buds were rotting.. fungicides, sprays nothing helped.. once when the moisty nights were over after the winter, the buds were doing ok.
     

Share This Page