Forum Software Updated: July 6, 2017

Discussion in 'Forum Announcements and Feedback' started by Daniel Mosquin, Jul 6, 2017.

  1. Daniel Mosquin

    Daniel Mosquin Renowned Contributor UBC Botanical Garden Forums Administrator Forums Moderator 10 Years

    Messages:
    8,848
    Likes Received:
    107
    Location:
    Vancouver, British Columbia, Canada
    If you notice anything wonky, let me know. The main software was updated, as were the resources, media gallery, and 6 plugins.

    I also unfortunately had to update the style, and messed up the instructions, I guess. So, some of the custom styling has gone missing until I have time to fiddle around with that again (I hope next week).
     
  2. Junglekeeper

    Junglekeeper Contributor 10 Years

    Messages:
    4,202
    Likes Received:
    57
    Location:
    Vancouver BC Canada
    Re: posting attachments. I noticed the name of an uploaded .jpg file is now replaced by 'blog.jpg' 'blob.jpg'. What is the reason for removing the original name? Would it not cause a problem for the Cherry Festival folks who encode information into the filename?

    Edit: Fixed typo.
     
    Last edited: Jul 31, 2017
  3. wcutler

    wcutler Renowned Contributor Forums Moderator VCBF Cherry Scout 10 Years

    Messages:
    5,737
    Likes Received:
    137
    Location:
    Vancouver, BC Canada
    Where are you seeing that, @Junglekeeper? I uploaded some photos the normal way last week. They were fine. Are you uploading them as described in
    Attach photos and files ?
    If not, could you describe how you're doing it?
    And, do you still get that blog.jpg filename when you do it as described on the Help page and video?
    Where are you uploading the photos?
     
  4. Junglekeeper

    Junglekeeper Contributor 10 Years

    Messages:
    4,202
    Likes Received:
    57
    Location:
    Vancouver BC Canada
    I haven't read the instructions. I just uploaded the photos the way I did before which is to click on the Upload button then select files from the dialog box that comes up. For an example of what happened, see this thread: Appreciation: - Flowers Beside Greenway. I'll do some tests in Test Bed when I get a chance.
     
  5. Junglekeeper

    Junglekeeper Contributor 10 Years

    Messages:
    4,202
    Likes Received:
    57
    Location:
    Vancouver BC Canada
    The original filename is displayed in the progress window while the file is being uploaded but is changed to blob.jpg upon completion. It makes no difference whether I do a multi- or single file upload.
     
  6. Daniel Mosquin

    Daniel Mosquin Renowned Contributor UBC Botanical Garden Forums Administrator Forums Moderator 10 Years

    Messages:
    8,848
    Likes Received:
    107
    Location:
    Vancouver, British Columbia, Canada
    I wonder if it is something on your end... could you send me one of the files you had uploaded to my email address. I've looked at other threads and the files retained their names.
     
  7. Junglekeeper

    Junglekeeper Contributor 10 Years

    Messages:
    4,202
    Likes Received:
    57
    Location:
    Vancouver BC Canada
    I'm using a different camera app than from before but the file naming format is identical, or so it appears. Anyway, I'll PM you one of the files.
     
  8. Junglekeeper

    Junglekeeper Contributor 10 Years

    Messages:
    4,202
    Likes Received:
    57
    Location:
    Vancouver BC Canada
    I uploaded a photo from the other camera app as well as a picture I downloaded from the web. They both attached as 'blob' so I don't think the problem lies with the nature of the photo.
     
  9. wcutler

    wcutler Renowned Contributor Forums Moderator VCBF Cherry Scout 10 Years

    Messages:
    5,737
    Likes Received:
    137
    Location:
    Vancouver, BC Canada
    I can't make that happen. I just uploaded some files of mine in the Testbed, into my last week's thread. And I saved a blob.jpg one, renamed it to Junglekeeper_blob.jpg and that's how it uploaded. but of course I don't have the original version. It sounds like something a virus would do (rename a photo to "blob" - isn't that the MO of a virus?), but by the time you've watched it upload with the original name, then the rest should have nothing to do with your computer, should it (that question is for @Daniel Mosquin)?

    It sounds like you were doing the upload the way the instructions say to do it.
     
  10. wcutler

    wcutler Renowned Contributor Forums Moderator VCBF Cherry Scout 10 Years

    Messages:
    5,737
    Likes Received:
    137
    Location:
    Vancouver, BC Canada
    @Junglekeeper, do you have another email address, or even your own email address, to which you could send a photo? The intent would be to test whether it's to do with the UBCBG forum or if it's your computer that is now doing that with any file sent.

    Oh, and I meant to thank you for thinking of me and how bad that would be for the VCBF postings!
     
  11. Daniel Mosquin

    Daniel Mosquin Renowned Contributor UBC Botanical Garden Forums Administrator Forums Moderator 10 Years

    Messages:
    8,848
    Likes Received:
    107
    Location:
    Vancouver, British Columbia, Canada
    Low possibility that it is a virus. Higher probability is that an unknown character in the file name can't be parsed and is forcing a convert to a default name.
     
  12. Junglekeeper

    Junglekeeper Contributor 10 Years

    Messages:
    4,202
    Likes Received:
    57
    Location:
    Vancouver BC Canada
    More information.

    The uploader's dialog box does not show a list of file types in the drop-down box. Is this normal? It allows 'All Files' but the upload aborts with the message "The uploaded file does not have an allowed extension." if I upload a .pdf file.

    Also tried switching to alternate uploader using profile setting, without effect. Note the uploader appeared to be the same after the switch; if I recall correctly, there was a difference in appearance sometime after the change over to Xenforo.
     
  13. Daniel Mosquin

    Daniel Mosquin Renowned Contributor UBC Botanical Garden Forums Administrator Forums Moderator 10 Years

    Messages:
    8,848
    Likes Received:
    107
    Location:
    Vancouver, British Columbia, Canada
    Ok, no problem when I upload the image.

    So, two possibilities I can think of: 1) something on your computer is scanning through anything you upload; 2) you need to do a hard refresh / clear cookies / cache clean--all of that is to possibly kick out an old clingy version of a javascript file stored locally on your computer that is refusing to be overwritten by a new version.
     
  14. Junglekeeper

    Junglekeeper Contributor 10 Years

    Messages:
    4,202
    Likes Received:
    57
    Location:
    Vancouver BC Canada
    What I tried just now, without success:

    1. Cleared cache and tried upload.
    2. Changed uploader profile preference, logged out, cleared cache, logged in, tried upload.

    Don't spend a whole lot of time on this if I'm the only one having this problem; I'm guessing it has to do with the fact that I'm using an old browser (which cannot be updated). It's not a big deal for me if the filename gets changed to 'blob'.
     
  15. Daniel Mosquin

    Daniel Mosquin Renowned Contributor UBC Botanical Garden Forums Administrator Forums Moderator 10 Years

    Messages:
    8,848
    Likes Received:
    107
    Location:
    Vancouver, British Columbia, Canada
    Yeah, I'd be interested to find out what happens if / when you switch to a modern browser.
     
  16. wcutler

    wcutler Renowned Contributor Forums Moderator VCBF Cherry Scout 10 Years

    Messages:
    5,737
    Likes Received:
    137
    Location:
    Vancouver, BC Canada
    I find it hard to believe that "blob" is a default name, unless a little joke by the XenForo folks - you could check whether they might have done that, as I probably still can't create a new post on their forum.

    I just tested (in Daniel's Test Bed thread) that pdf files are an allowed extension. I made a copy of a pdf with an invalid extension. When I tried to upload it, it didn't display the file in the file list. So it doesn't need to tell you what is valid - it seems to just not display ones that are not valid.

    @Daniel, was @Junglekeeper's file sent in a way that we know it would not change name or size? I would think a Dropbox transfer would change nothing, unlike an email transfer. I could set up a Dropbox for Junglekeeper (@Junglekeeper, would need your email) and test the file after it's copied there.

    OK, we've tested that, as Daniel received the sent file with its name.
     
  17. Daniel Mosquin

    Daniel Mosquin Renowned Contributor UBC Botanical Garden Forums Administrator Forums Moderator 10 Years

    Messages:
    8,848
    Likes Received:
    107
    Location:
    Vancouver, British Columbia, Canada
    I don't think there's anything more to be done.

    BLOB is a database term for a large amount of data, so it isn't out of the question that it is a default.
     
  18. Junglekeeper

    Junglekeeper Contributor 10 Years

    Messages:
    4,202
    Likes Received:
    57
    Location:
    Vancouver BC Canada
    For what it's worth there is a work-around for this problem: Bypass the uploader and simply drag and drop the file into the text area. Are there any drawbacks or caveats in using this method?
     
  19. wcutler

    wcutler Renowned Contributor Forums Moderator VCBF Cherry Scout 10 Years

    Messages:
    5,737
    Likes Received:
    137
    Location:
    Vancouver, BC Canada
    If we let you do it, then I would assume it's ok. What works, works.
    I'd love to see that file copied some place I can see it unchanged by the sending process. Set up a Dropbox yourself, put the file in and invite me to see it?
     
  20. Junglekeeper

    Junglekeeper Contributor 10 Years

    Messages:
    4,202
    Likes Received:
    57
    Location:
    Vancouver BC Canada
    I don't think we need to test that anymore. I sent Daniel a sample file via email which he successfully uploaded to a thread in Test Bed. That together with my success in uploading with a drag-and-drop suggests a problem in communication between my browser and the uploader. I think we can put this to rest. Do you think it would be useful to add this work-around to the file upload instructions as a footnote in case someone else encounters the same problem?
     
  21. wcutler

    wcutler Renowned Contributor Forums Moderator VCBF Cherry Scout 10 Years

    Messages:
    5,737
    Likes Received:
    137
    Location:
    Vancouver, BC Canada
    I'm inclined to wait to see if someone else mentions it or if I notice that filename.
     

Share This Page